Leere Zeilen zusammenfassen

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
Marlon Orth
Beiträge: 3
Registriert: Fr 11. Okt 2019, 21:48

Leere Zeilen zusammenfassen

Beitrag von Marlon Orth » Do 16. Jan 2020, 16:09

Ich habe einen Kontoauszug digitalisiert.

Die Struktur ist wie folgt

Code: Alles auswählen

Datum           Buchungstext                        Ausgaben        Einnahmen       Guthaben /Kredit
30.11.19        Bezeichnung1                        Betrag1 €
02.12.19        Bezeichnung2                                        Betrag2 €
                Bezeichnung2-Fortsetzung
02.12.19        Bezeichnung3                        Betrag3 €
                Bezeichnung3-Fortsetzung
                Bezeichnung3-Weitere Fortsetzung
                ....
                
Mal gibt es längere Buchungstexte, damit mehr Zeilen ohne extra Datum, mal weniger, mal nur eine.

Ich will sie umwandeln in

Code: Alles auswählen

Datum           Buchungstext                                                                Ausgaben        Einnahmen       Guthaben /Kredit
30.11.19        Bezeichnung1                                                                Betrag1 €
02.12.19        Bezeichnung2 Bezeichnung2-Fortsetzung                                                       Betrag2 €
02.12.19        Bezeichnung3 Bezeichnung3-Fortsetzung Bezeichnung3-Weitere Fortsetzung                      Betrag3 €

D.h. je nachdem wie lange kein weiteres Datum kommt, die Bezeichnung an den Buchungstext anhängen, in dessen Zeile das letzte Datum stand.

Wie mache ich das?

echo
Beiträge: 73
Registriert: Fr 1. Dez 2017, 12:49

Re: Leere Zeilen zusammenfassen

Beitrag von echo » Do 16. Jan 2020, 17:26

Hallo, du könntest das in einer Hilfsspalte machen:
A2 = oberstes Datum
B2 = oberster Text
Formel für Hilfsspalte ( hier Spalte E Zeile 2) zum runter kopieren:
=WENN(A3<>"";B2;B2&";"&E3)

Die Texte werden neben dem Datum verkettet und durch ein Semikolon getrennt. (";")
Gruß Holger

Antworten