>> Wie mache ich einen Screenshot?

#Wert Meldung in LibreOffice Calc

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
Klausi
Beiträge: 5
Registriert: Di 15. Nov 2016, 14:57

#Wert Meldung in LibreOffice Calc

Beitrag von Klausi » Do 9. Nov 2017, 11:46

Hallo liebe Forumsmitglieder,

ich weiß nicht, ob dieser Eintrag hier richtig ist.

Wir haben in letzter Zeit einige Probleme mit Formeln in Calc Dateien die ursprünglich mit OpenOffice Calc erstellt worden sind.

Beispiel:

Feld a10 =WENN(A1="";"";A1)
Feld a11 =WENN(A2="";"";A2)
Feld a12 =WENN(A11+A10=0;"";A10+A11)

Wenn nun a1 und a2 leer sind erscheint in a12 die Meldung #Wert.
Ich vermute das LibreOffice das "" anders (wahrscheinlich als Text) interpretiert und dadurch die unschöne Meldung erscheint.

In OpenOffice (Version 4.x) erscheint keine Meldung.

Meine Fragen lt. nun
  • Ist meine Vermutung richtig?
  • Wie konvertieren wir am besten unsere alten OpenOffice Calc Dateien?
  • Gibt es für eine sinnvollere Lösung für "", also wenn in einer Wenn-Formel nichts geschechen soll?
Vielen Dank im Voraus
Klausi



Mondblatt24
Beiträge: 108
Registriert: Do 9. Mär 2017, 09:53

Re: #Wert Meldung in LibreOffice Calc

Beitrag von Mondblatt24 » Do 9. Nov 2017, 11:59

Hallo,
wie soll man an dem Beispiel erkennen woran es hakt?

Hänge bitte eine Datei mit dem Fehler an.

Gruß Peter
LO 5.3.7; LO 6.0.0 RC1; LO 5.4.3 Portable; AOO Portable 4.1.4

mikele
Beiträge: 406
Registriert: Sa 23. Jul 2011, 22:09

Re: #Wert Meldung in LibreOffice Calc

Beitrag von mikele » Do 9. Nov 2017, 12:49

Hallo,
deine Vermutung ist richtig.
Lösungen:
1) Über ->Extras->Optionen->LibreOffice Calc->Formel->Detaillierte Einstellungen für Berechnungen->Benutzerdefiniert->Details->Leere Zeichenketten als Null behandeln auf WAHR setzen.
2) aus

Code: Alles auswählen

 =WENN(A11+A10=0;"";A10+A11)
wird

Code: Alles auswählen

 =WENN(SUMME(A11;A10)=0;"";A10+A11)
oder (besser)

Code: Alles auswählen

 =WENN(ODER(A11="";A10="");"";A10+A11)
3) aus
=WENN(A1="";0;A1)
und Nullwerte ausblenden (z. B. per Zahlenformat "Standard;;;")
...
Gruß,
mikele

Klausi
Beiträge: 5
Registriert: Di 15. Nov 2016, 14:57

Re: #Wert Meldung in LibreOffice Calc

Beitrag von Klausi » Do 9. Nov 2017, 14:55

Vielen, vielen Dank für die Antwort mikele.

Über ->Extras->Optionen->LibreOffice Calc->Formel->Detaillierte Einstellungen für Berechnungen->Benutzerdefiniert->Details->Leere Zeichenketten als Null behandeln auf WAHR setzen. ---> Das ist es was ich brauchte, ohne ne Menge Formel anpacken zu müssen.

Nochmals vielen Dank und viele Grüße
Klausi


Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast