2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
bax5000
Beiträge: 3
Registriert: Mi 7. Nov 2018, 14:28

2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

Beitrag von bax5000 » Mi 7. Nov 2018, 14:33

Hallo!

Hallo!

Ich habe zwei Tabellen mit Produktcodes wobei die zweite Tabelle nicht alle diese Codes enthält. Ich möchte jetzt jeden einzelnen Code aus Tab 1 (die erste Spalte) in Tab 2 suchen und bei Erfolg dann den zweiten Wert der Zeile auch an die zweite Stelle der Zeile in Tab 1 einfügen.

Beispiel:

Tab 1 Tab 2

Code 1, 0,..... Code 1, 12,.....

Code 2, 0,...... Code 3, 5,.....

Code 3, 0,...... Code 5, 7,.....

Code 4, 0,...... Code 6, 4,.....

Danach soll Tab 1 so aussehen:

Tab 1

Code 1, 12,.....

Code 2, 0,......

Code 3, 5,......

Code 4, 0,......

Wäre wirklich toll wenn mir hier Jemand helfen könnte.

Danke!

Kalk
Beiträge: 233
Registriert: Do 6. Feb 2014, 19:45

Re: 2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

Beitrag von Kalk » Mi 7. Nov 2018, 18:28

Hallo,

Formel in Spalte C, wenn in Spalte A und B die Werte stehen.

Code: Alles auswählen

=WENN(ISTNV(SVERWEIS(A1;Tabelle2.A$1:B$7;2;0));B1;SVERWEIS(A1;Tabelle2.A$1:B$7;2;0))

Gruß Kalk

bax5000
Beiträge: 3
Registriert: Mi 7. Nov 2018, 14:28

Re: 2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

Beitrag von bax5000 » Mi 7. Nov 2018, 19:30

Danke Kalk!

Ich werde das morgen gern testen.

Gruß!

ps: Könntest Du die Formel evtl. kurz etwas erklären damit ich sie evtl. zukünftig anpassen kann? Wäre doppelt nett!

Kalk
Beiträge: 233
Registriert: Do 6. Feb 2014, 19:45

Re: 2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

Beitrag von Kalk » Mi 7. Nov 2018, 20:11

Hallo,

Code: Alles auswählen

SVERWEIS(A1;Tabelle2.A$1:B$7;2;0)
A1 = ist der Suchbegriff
Tabelle2.A$1:B$7 = Bereich in dem gesucht wird.
2 = die 2 Spalte im Bereich der gesucht wird.
0 = nicht sortiert.

Der Rest kann mit F1 Hilfe nachgelesen werden.

Gruß Kalk

bax5000
Beiträge: 3
Registriert: Mi 7. Nov 2018, 14:28

Re: 2 Tabellen nach Spalte 1 vergleichen und bei Übereinstimmung zweiten Wert der Zeile aus Tab2 nach Tab1 kopieren?

Beitrag von bax5000 » Do 8. Nov 2018, 09:50

Nochmals besten Dank!
Klappt wunderbar.

Antworten