weniger als 10 Ziffern in einer Zelle herausfiltern

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
mihe
Beiträge: 20
Registriert: Mi 23. Sep 2015, 17:23

weniger als 10 Ziffern in einer Zelle herausfiltern

Beitrag von mihe » Fr 11. Jan 2019, 12:28

Hallo,

ich habe eine Calc Tabelle mit Artikelnummern. All diese Artikelnummern haben mind. 10 Ziffern (Buchstaben und Zahlen). Ich habe leider die Calc Tabelle als Standard formatiert. Dabei ist mir aufgefallen, dass bei den Artikelnummern, die eine 0 am Anfang hatten, die 0 entfernt wurde. Ich möchte gerne wissen, wie ich einen Filter machen kann, womit ich die Artikelnummern herausfiltern kann, die weniger als 10 Ziffern enthalten.

Vielen Dank im Vorraus!

Euer Michi

Jodokus
Beiträge: 626
Registriert: Mo 8. Feb 2010, 17:13

Re: weniger als 10 Ziffern in einer Zelle herausfiltern

Beitrag von Jodokus » Fr 11. Jan 2019, 15:48

Hallo Michi,
wenn es nur um die führende Null geht, dann reicht in einer Hilfsspalte die Formel

Code: Alles auswählen

=WENN(LÄNGE(A1)=9;"0"&A1;A1)
. Die neunen Wert kannst du dann kopieren un via Inhalte einfügen in die Spalte mit den Artikelnummern einfügen.

Gruß
Jodokus
Arbeiten am Computer ist wie U-Boot fahren.
Machst du ein Fenster auf, fangen die Probleme an.

mihe
Beiträge: 20
Registriert: Mi 23. Sep 2015, 17:23

Re: weniger als 10 Ziffern in einer Zelle herausfiltern

Beitrag von mihe » Fr 11. Jan 2019, 17:12

Hallo Jodokus,

Leider ist das die falsche Formel, die ich suche. Ich möchte die Zeilen mit einem X odersowas markieren, die weniger als 10 Ziffern haben.

Gruß Michi

echo
Beiträge: 50
Registriert: Fr 1. Dez 2017, 12:49

Re: weniger als 10 Ziffern in einer Zelle herausfiltern

Beitrag von echo » Fr 11. Jan 2019, 20:47

Hallo
wie wäre es mit der bedingten Formatierung?
Alle Zellen markieren, angenommenem die oberste Zelle ist A1
Start > bedingte Formatierung > Formel zur Ermittlung ... >
=LÄNGE(A1)<10
Format einstellen > OK

oder DITO als Formel für X
=wenn(LÄNGE(A1)<10;"X";"")

Gruß Holger

Antworten