leerzellen ignorieren

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
redeagle56
Beiträge: 37
Registriert: Sa 26. Sep 2015, 20:37

leerzellen ignorieren

Beitrag von redeagle56 » So 27. Mai 2018, 21:50

Hallo,
ich habe ein Problem mit dem sortieren von Daten.
Ich will aus einer Spalte Daten auslesen und ohne Leerzellen in eine andere Spalte übernehmen.
Kann mir bei diesem Problem jemand helfen?
Habe schon gegoogelt, aber nichts gefunden. Bezieht sich immer auf Excel.

MfG Günter

Mondblatt24
Beiträge: 151
Registriert: Do 9. Mär 2017, 09:53

Re: leerzellen ignorieren

Beitrag von Mondblatt24 » Mo 28. Mai 2018, 04:52

Hallo,
schon mal mit Daten→Sortieren versucht?
Und dort unter Optionen Sortierergebnis ausgeben nach... Zielzelle eingeben.

Ach ja, vorher den zu sortierenden Bereich/Spalte markieren.

Gruß Peter


P.S.: Dann gibt es da auch noch die Funktionen KKLEINSTE() und KGRÖSSTE().
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

redeagle56
Beiträge: 37
Registriert: Sa 26. Sep 2015, 20:37

Re: leerzellen ignorieren

Beitrag von redeagle56 » Mi 6. Jun 2018, 21:21

Hallo Mondblatt24,
du hast mich falsch verstanden. Ich will nicht manuell sortieren.
Es sollte genau wie bei EXCEL über eine Formel (Matrixformel) funktionieren.
Ich bekomme es aber nicht gebacken. Wäre für Hilfe dankbar.
Hat Jemand eine zündende Idee?

MfG Günter
Dateianhänge
Wochenkalender.ods
(23.55 KiB) 18-mal heruntergeladen

Jodokus
Beiträge: 603
Registriert: Mo 8. Feb 2010, 17:13

Re: leerzellen ignorieren

Beitrag von Jodokus » Do 7. Jun 2018, 05:49

Hi,
in meinem LO 6.0.4 gehts genau so.

Ich hab deine Formel aus C19 nach K5 kopiert. Sie steht dann da ohne die geschweiften Klammern. Jetzt klickst du hinten in die Eingabezeile und drückst Strg-Umschalt-Enter.

Gruß
Jodokus

P.S.: Sorry, hatte übersehen, dass ich hier im AOO-Forum bin - in AOO funktionierts mit der Formel nicht.
Arbeiten am Computer ist wie U-Boot fahren.
Machst du ein Fenster auf, fangen die Probleme an.

Jodokus
Beiträge: 603
Registriert: Mo 8. Feb 2010, 17:13

Re: leerzellen ignorieren

Beitrag von Jodokus » Do 7. Jun 2018, 09:30

Hi, ich nochmal

eine leichter verständliche Variante - jedenfalls für mich.
Du nutzt die Spalte F ebenfalls als Hilfsspalte und trägst in F5

Code: Alles auswählen

=WENN(G5="";"";MAX($F$4:F4)+1)
ein und kopierst die Formel bis F11.
Anschließend kannst du in K5 die Formel

Code: Alles auswählen

=WENN(ANZAHL2($K$4:K4)>MAX($F$5:$F$11);"";SVERWEIS(ZEILE(A1);$F$5:$G$11;2;0))
eintragen und bis K11 kopieren.

Gruß
Jodokus
Arbeiten am Computer ist wie U-Boot fahren.
Machst du ein Fenster auf, fangen die Probleme an.

Mondblatt24
Beiträge: 151
Registriert: Do 9. Mär 2017, 09:53

Re: leerzellen ignorieren

Beitrag von Mondblatt24 » Do 7. Jun 2018, 09:56

Hallo,
da ich davon ausgehe das die Hilfsspalten ausgeblendet/versteckt werden, würden die Fehler nicht weiter stören.
Deshalb sieht mein Vorschlag so aus.

Wochenkalender A.ods
(28.9 KiB) 17-mal heruntergeladen

Gruß Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

redeagle56
Beiträge: 37
Registriert: Sa 26. Sep 2015, 20:37

Re: leerzellen ignorieren

Beitrag von redeagle56 » Sa 16. Jun 2018, 13:04

Hallo,
ich bedanke mich für die Hilfe. Das Problem ist gelöst.

MfG Günter

Antworten