>> Wie mache ich einen Screenshot?

Wertabhängige Nummerierung

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
psrnck
Beiträge: 9
Registriert: Fr 28. Jul 2017, 12:47

Wertabhängige Nummerierung

Beitrag von psrnck » Mi 9. Aug 2017, 11:43

Hallo,
ich habe folgende Tabelle:
Sample.jpg
Sample.jpg (48.39 KiB) 366 mal betrachtet
In der 'Id'-Spalte brauche ich eine Nummerierung, die jedes Mal von vorne beginnt, wenn die Nummerierung im GRIDCODE einen neuen Durchlauf beginnt. (Ich habe die Werte, ab denen im GRIDCODE ein neuer Durchlauf beginnt, fett markiert)

Beispiel: In A2 beginnt der erste Durchlauf und endet mit A5. Der nächste Durchlauf beginnt dann mit A6 und endet mit A11.
Ich hab mal ein Beispiel per Hand gemacht:
Sample2.jpg
Sample2.jpg (57.34 KiB) 366 mal betrachtet
Hättet ihr eine Idee wie man dies machen könnte? Mein Datensatz hat mehr als 9000 Zeilen, ich kann die Nummerierung nicht per Hand machen....

Ich hoffe ich konnte mein Problem verständlich schildern :)

Grüße,
Philip

Edit:
Mir ist eingefallen, welche Kriterien man nutzen könnte.
Die Nummerierung in der 'Id'-Spalte beginnt von neuem wenn:

- die Differenz zwischen des GRIDCODE-Wertes in einer Zelle und des GRIDCODE-Wertes in der Zelle darüber negativ ist(Beispiel A)
ODER
- die Differenz zwischen des GRIDCODE-Wertes in einer Zelle und des GRIDCODE-Wertes in der Zelle darüber größer als 1 ist (Beispiel B)
ODER
- der GRIDCODE-Wert einer Zelle identisch ist mit dem GRIDCODE-Wert in der Zelle darüber, bzw. die Differenz zwischen den beiden '0' ist (Beispiel C)
Sample3.jpg
Sample3.jpg (68.83 KiB) 350 mal betrachtet
Wie könnte man sowas in einer Formel o.ä. umsetzen?



Kalk
Beiträge: 200
Registriert: Do 6. Feb 2014, 19:45

Re: Wertabhängige Nummerierung

Beitrag von Kalk » Mi 9. Aug 2017, 15:07

Hallo,

in B2 1 eintragen.
in B3 dann:

Code: Alles auswählen

=WENN(A3=A2+1;B2+1;1)

Gruß Kalk

Jodokus
Beiträge: 574
Registriert: Mo 8. Feb 2010, 17:13

Re: Wertabhängige Nummerierung

Beitrag von Jodokus » Mi 9. Aug 2017, 15:55

Hi,

Code: Alles auswählen

=WENN(ODER(ABS(A2-A1)>1;A2-A1=0);1;B1+1)
Gruß
Jodokus
Arbeiten am Computer ist wie U-Boot fahren.
Machst du ein Fenster auf, fangen die Probleme an.

psrnck
Beiträge: 9
Registriert: Fr 28. Jul 2017, 12:47

Re: Wertabhängige Nummerierung

Beitrag von psrnck » So 13. Aug 2017, 11:15

Hat geklappt, danke! :)


Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste